installation proble...
 
Notifications
Clear all

[Solved] installation problem

29 Posts
8 Users
1 Likes
720 Views
0
Topic starter

Hello,

Must FreeCAD and paraView be installed in the default installation directory? Each installation attempt will encounter conflicts.

 

It would be better if a more complete installation package could be provided.

3 Answers
1

Hi Walter,

Thank you for your question.

At present, GeoXPM only detects the installation location of FreeCAD and Paraview from the ProgramFiles folder. Therefore, it is essential to maintain the default installation directory on the C:\ drive.

Walter Topic starter 16/06/2023 11:46 am

@tienlk2004 Thanks, I see. It's a nice program, a great start.

Tien Nguyen (Smith) Tien Nguyen (Smith) 16/06/2023 11:59 am

Thank you, Walter! I'm glad you find the program nice and see it as a great start.
If you have any further questions, please don't hesitate to ask.

alrm 17/06/2023 11:18 pm

@tienlk2004
Hello,
I've installed FreeCAD and Paraview in their default's installation directory, I have the same problem.

0

Hello,

I have successfully installed both FreeCAD and GeoXPM (at least that is what the system said).

But, when I run GeoXPM i get this error

11:06:55  Exception while processing file: C:/Users/name.surname/AppData/Roaming/FreeCAD/Mod/GeoXPM/GeoXPMMacro.py [Unknown file: C:/Users/name.surname/AppData/Roaming/FreeCAD/Mod/GeoXPM/GeoXPMMacro.py]

FreeCAD and GeoXPM are installed at default folder using admin privileges.

Is there any way to change path to py file?

With kind regards

Tien Nguyen (Smith) Tien Nguyen (Smith) 30/06/2023 11:51 am

Hi @vjagodnik,
GeoXPM is implemented an addon for FreeCAD that requires the files to be placed inside the Mod folder of FreeCAD. Otherwise, you will need to manually load the addon from FreeCAD. Could you please check if the file "C:/Users/name.surname/AppData/Roaming/FreeCAD/Mod/GeoXPM/GeoXPMMacro.py" exists?
If the file doesn't exist, please (re-)install GeoXPM.
If the file is present but FreeCAD is unable to access it, my best guess would be that the issue is caused by the dot in the username.

vjagodnik 30/06/2023 5:01 pm

Success regarding the start of program and mod.
The issue now is the error I get that there is no "Run.out" file in the folder containing output files.
If I create a file myself, I get the computation error.

Tien Nguyen (Smith) Tien Nguyen (Smith) 30/06/2023 5:12 pm

@vjagodnik
I'm glad that you were able to get the program running. The 'Run.out' file contains the output log of the simulation.
If the file is not present, it could indicate one of two things:
1. The program attempted to write the output files but failed due to insufficient write permissions. To resolve this, please ensure that you have the necessary write permissions for the program and that there are no special characters included in the project paths (where you save the project).

2. The error could also be caused by the program terminating or the program call not being executed properly. In such a case, I recommend using a sample project to test run GeoXPM first ( https://geoxsph.com/wp-content/uploads/2023/03/GranularFlow2D.zip). Incorrect configuration, especially with staging, could cause the program to terminate immediately, resulting in no output.
If you encounter the error even when using a sample project, you should check if any antivirus program is blocking the program calls or if another program has deleted GeoXPM's files (which can occur, particularly with University computers). You can verify this by checking if the two files, 'runsph' and 'runsph3d,' exist in the directory '%appdata%/FreeCAD/Mod/GeoXPM/binaries/'.

0

Dear all,

I'm expiriencing the same problem of user vjagodni. After starting the programme the following error is reported:

"Exception while processing file: Rog/AppData/Roaming/FreeCAD/Mod/GeoXPM/GeoXPMMacro.py [Unknown file: Rog/AppData/Roaming/FreeCAD/Mod/GeoXPM/GeoXPMMacro.py]"

I installed the programme keeping the antivirus and microsoft firewall off. Please note that my user does not have any dot. As suggested by other users I also kept the installation location of FreeCAD and Paraview from in the ProgramFiles folder.

Could you please help me in solving this problem?

Best regard

Pietro

 

Tien Nguyen (Smith) Tien Nguyen (Smith) 11/07/2023 9:52 am

@pietro-mazzuca, the error message "Unknown" suggests that FreeCAD cannot process the file. Please try the following: Open FreeCAD, go to the Macro menu, select Macro, and browse to the GeoXPM macro folder location ("%appdata%/FreeCAD/Mod/GeoXPM/") then execute the GeoXPMMacro.py file manually.

Pietro Mazzuca 12/07/2023 6:00 am

Many thanks for your quick response. Following your suggestions I'm now able to open correctly the software.
However, I have another problem, I downloaded an example from your library (that regarding the soil column), but when I try to run the analyses the following error is given by the programme:

21:56:53 Traceback (most recent call last):
21:56:53 File "", line 77, in on_sph_sim_finished
21:56:53 FileNotFoundError: [Errno 2] No such file or directory: 'C:/Users/Asus Rog/Downloads/GranularFlow2D (1)/GranularFlow2D/GranularFlow2D_out/Run.out'

I have the write permission for the programme, in addition both two files, 'runsph' and 'runsph3d,' exist in the directory '%appdata%/FreeCAD/Mod/GeoXPM/binaries/'.

Could you please help me in solving this problem?
Many thanks in advance.
Best regards
Pietro

Tien Nguyen (Smith) Tien Nguyen (Smith) 12/07/2023 10:29 am
This post was modified 9 months ago by Tien Nguyen (Smith)

@pietro-mazzuca It seems your problem is similar to vjagodnik's. I'm not sure if vjagodnik has solved the problem though. I think there is a link between the 2 problems where FreeCAD is not able to load the macro and GeoXPM is not able to execute and this seems to affect a few users.

@Anyone, if you would like, I can offer a Zoom meeting where we can try to figure out and solve the problems together. This will also help other users. So, if anyone is currently facing the same issue and wants to help, please feel free to contact me. You can reach me through Messenger, LinkedIn, or GeoXPM's contact form.

https://www.facebook.com/smith.ed.547

https://www.linkedin.com/in/tien-nguyen-57a8aa1a3/

https://geoxpm.com/contact/